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A DFD is not the same as 
much less specific with reg d 
around the system than is a FD. On the other hand, a flow chart is much more specific and 
physical than a DFD with 
more flexible and has a mo
 

ata flow diagramming is not designed to show materials flow, just data. For example, if you 
 modeling a bookstore

transaction items are hand lves 
would not. The books are  
loading dock to the shelve part 
of data flow diagramming
 
In any structured analysis 
summary of the overall sy
outputs, and is sometimes 
less specific than the way 
It should involve only one

ource/sinks). In the example that follows, you use only one process and two source/sinks, 
ough a top-level diagram could contain a few more of each. You break down (decompose) 
ese top-level elements into more specific processes and flows.  Some methodologies and 

 a single process to represent the highest level of the data flow diagram. 
his is called a context diagram, and only one process is allowed on a context diagram to 
esignate the entire system. For child diagrams, though, you can have multiple processes on 
ny diagram. 

Data Flow Diagram

VIEW 
bed in Lesson 4 – Structured  Modeling Techniques, a data flowA

used for process modeling. This modeling technique shows the flow an
ata without regard to the details of the data structure or type. It clearly representsd

transaction ran ations occur in your system. 
 

a flow chart, although there are certain similarities. A flow chart is 
ard to how pieces of data are broken down, combined, and move
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regard to how processing is performed. A data flow diagram is 
re general applicability than does a flow chart. 
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materials, and their movement from the publisher to the store’s
s to the bag in the customer’s hand is materials flow and not a 
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methodology, the first task is to draw a top-level diagram, a simple 
stem. It shows the system environment and major inputs and 
referred to as the basic problem statement. This is usually much 
most people picture a system because so many details are omitted. 
, two, or three processes and a very few external entities 
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The idea behind creating a general top-level diagram is twofold: 

• To ensure agreement and understanding of the fundamental, overall mission of the 
system. There is confusion on this more often than is realized, and the details can 
rarely work well if the overall mission is unclear. 

• To make explicit the source and derivation of the more detailed operations of the 
system. Often it is the second or third level of design that is the taken-for-granted 
starting point. Making the derivation explicit is important both for the design 
discipline itself and for the completeness of the resulting documentation. If you start 
Visible Analyst at the highest level, the tracking of all subsequent derivations 
automatically results from the data repository documentation. 

 
There are four meaningful objects that appear on data flow diagrams: 
 
Process   The process symbol is accessed with the first symbol button on the  

control bar. If you are using Yourdon rules, a process is 
represented by a circle.  For Gane & Sarson rules, a process is 
represented by a rounded-corner square. 
 
A process signifies that something is happening to transform data. 
At the highest level you could show the whole bookstore as a 
single process. 

 
After creating the context (or high-level) diagram, you then break 

ing the various 
sses representing the 

ctions
rocesse  

This is d
child dia
inputs an
what is g
numbers 
8-1. 

 
 
 
  

that diagram down into processes represent
departments of the store, then into proce
fun  of the departments, then into subdivisions of these 
p s, and so forth to as fine a level of description as you wish.

one by “nesting” or decomposing a process and creating a 
gram at a greater level of detail, one that shows all of the 
d outputs to the parent process and allows you to show 
oing on inside it. Processes have numbers, and those 
reflect the decomposition hierarchy, as shown in Figure 
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           Figure 8-1  A 

ata Store (or File)  A data store or file is accessed using the second symbol  
button on the control bar. If you are using Yourdon rules, 
a file is represented by two horizontal parallel lines. For 
Gane & Sarson rules, a data store is shown as a rectangle 
with the right side open, and it has a number. A data store 
is a place where data is kept while it is not actively being 
processed. Your process model does not show how it is 
stored, whether encoded on magnetic disk or scribbled on 
the back of an envelope, just that it is stored. Data can 
only enter a data store from a process and can only leave a 
data store to a process. The detailed data element in a data 
store can be defined in the Visible Analyst repository. 

Process Numbering Scheme 
 
D
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External Entity (or   An external entity is accessed using the last symbol  
Source/Sink)   button on the control bar. It is represented by a large 

square under Yourdon rules, or a square drawn with relief 
under Gane & Sarson rules. An external entity is 
something outside the boundary of the system you are 
modeling that either sends data to your system or receives 
data from it. It is effectively a black box, in that what 
happens inside the external entity is not material to your 
system description. It is only there to make clear some of 
the environment in which your system resides. External 
entities are optional. A net input data flow can just as well 
be shown coming from nowhere as from an external 
entity. Note that an external entity has no relation to the 
entity that is a part of entity relationship modeling. It is 
simply an unfortunate duplication of terminology. 

 
Data Flow   A data flow depicts the movement of one to many items  

of data. Data can enter a system from outside, such as the 
entries that appear on a publisher’s invoice or a packing 
list. (The invoice data flow is shown entering a process—
it must enter a process—where it is examined and acted 
upon.) This process might send some of the data to be 
stored, some to be printed, some to be ignored. These 
invoice data elements may or may not be combined with 
elements from other input data flows and may then exit 
the process as parts of other data flows. To draw a data 
flow line, click on a line type in the control bar. 
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Yourdon/DeMarco

0

Process File Source/Sink

Gane & Sarson

1

D

Process Data Store External Entity

1

D

Métrica and SSADM

Process Data Store External Entity

                                 
 
   Figure 8-2  Data Flow Diagramming Symbols 

Note 
� In Yourdon methodology,  names of data flows contain hyphens instead of 

spaces. When you enter a space in a data flow name, Visible Analyst uses a 
hyphen. 

 
This lesson leads you through the diagram creation process for a Gane & Sarson-based 

 
are shown. Also, you see how the sy
Analyst. You build errors into your  
identified by the Analyze function.

process model. Basic drawing and decomposing a process into a subordinate “child” diagram
stem is validated using the rules capabilities of Visible 

 diagram to demonstrate the types of errors that can be
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CREATING AND POP
The basic procedure for creating a t
the unstructured diagram type. The  
licking the box at the bottom of the New agram screen, a process symbol number 0 is 

m is 

 
This diagram has already been crea
and enter repository information. It
top-level diagram of the DFDs you
diagram called Driver’s Licensing S
Open Diagram from the File menu
a diagram type has a plus sign next
created.  Click the plus sign to disp
diagram you would like to open.  (Y
to the diagram type name.)  
 
To close a diagram, click the control button in the top left corner of the diagram window and 
select Close, double-click the control button, or choose Close Diagram from the File menu. 
 

NESTING A PROCESS 
In this unit, you structurally decompose a process symbol. This is also called “nesting” or 
“exploding” a process. The File menu contains the Nest function for this purpose; the 
submenu contains the Explode function. Explode can also be found by clicking the right 
mouse button on a process symbol that you want to model in more detail to display its Object 
menu, and then selecting Explode. 
 
If the process has not previously been decomposed, this generates a “child” diagram from this 
“parent” process. All of the data flows attached to the parent process are automatically 
“dragged down” to the child diagram by the Nest function. These flows can be attached to the 
lower-level processes that you create on the child diagram. Those lower-level processes can 
then be nested further to increase the level of detail. In the current example, the child diagram 
was created by the Spawn function that you executed in Lesson 6 – Functional Decomposition 
Diagrams, and the processes you added to the FDD were placed on it. 
 
Open the Diagram: 1 From the File menu or the open diagram button on the  

control bar, open the data flow diagram DMV System, if 
his is the 

context diagram for this project. 

ULATING A TOP-LEVEL DIAGRAM 
op-level DFD is the same as creating a new diagram for 

ference is that if you choose a context diagram, byonly dif
Dic

automatically placed on the diagram; and you are prompted for its name. A context diagra
permitted only one process symbol. You can add data flows and other symbols to the diagram. 

ted for you so that you do not have to draw the diagrams 
 is named DMV System and is shown in Figure 8-9, the 
 spawned from your FDD. This diagram also has one child 
ystem. You can display a list of diagrams by selecting 
, or by clicking the Open button on the control bar. When 

 to it, it means that diagrams of that type have been 
lay the list of existing diagrams, then double-click the 
ou can hide the list again by clicking the minus sign next 

it is not still open from a previous lesson. T
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Select a Process:  2 Click the right mouse button on the process Driver’s  
Licensing System to open its Object menu, and choose  
Explode. This opens the existing child diagram Driver’s  
Licensing System and is an alternate way to navigate  
between the diagrams of your project, avoiding the File  
menu. 

Click the right mouse button on the process labeled  
Issue License and choose Explode. The flows attached to
the parent pro

 
Explode It:  3 

 
cess are dragged down to the spawn-created 

iagram entitled Issue License, where the three process 
symbols from the functional decomposition diagram were 
placed. Maximize the diagram. The dragged-down flows 

e child diagram, input flows 
e right. (See Figure 8-3.) 

Since yo  move the symbols on the diagram 

                  
                   Figure 8-3  Child Diagram With Dragged-Down Flows 
   

d

are lined up on the sides of th
on the left, output flows on th

u did not
before nesting, it is possible that the dragged-down flows 
were drawn over a symbol. 
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Edit the Diagram: 4 

int. 
a 

, it changes color; and the 
line becomes a dashed line as it is moved on the diagram. 

e 

Move the symbols and attach the flows as shown in  
Figure 8-4. To move a symbol, click and drag it with the 
left mouse button. To attach the lines, click one endpo
Then click the left mouse button on the middle of the dat
flow and drag the line so that it is positioned correctly. 
When the data flow is selected

Do the same for the other data flows.  (Ignore for now th
other flows you see in Figure 8-4; you add them later in 
this section.) 
 

  

ram 

� When you want to show a data flow line (or another type of line) as attached to a 
process (or another type of symbol), you must drag the end of the line into 

t with t symb  on, Visible Analyst 
redraws your connection at the outer edge of the symbol. 

 
Add Flows and Text: 5 

ph. Since these are internal flows, as opposed to 
et input or net output data flows7appearing on the parent, 

                                                          

 
              Figure 8-4  The Completed Diag
 

Note 

contac he ol.  With the Auto Connect option

Add two new data flows: License-Approval and  
Photogra
n
the Nest function could not create them. 

 
7For a full explanation of net input and output flows, please see the Visible Analyst Operation 
Manual or the online help. 
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Change Line Format: ight  

nd 
nd 
ow 

rsor 

mouse button.  Release the left mouse 
button to save the change. 

7 Click the T button on the control bar to add the caption  
text “Issue License” to display the diagram title on the 
diagram. Note that there is a way to do this automatically 
by using boilerplates. You can read about this in the 
Visible Analyst Operation Manual or in the online help 
system.  (Boilerplates are not available in the Education 
Editions of Visible Analyst.) 

 
Add a File:  8 If you wish, you can add the file DMV Database to the  

diagram. Since it appears on the context diagram, this is 
not necessary, but some people feel that showing it on a 
lower-level diagram adds clarity. Move the flow New 
Licensee-Record to attach it to the file DMV Database.  A 

e when the endpoint 
of the line is touching the edge of the symbol. (It does not 

 
Save:   9 
 

REATING A NEW DI
ious sections of this lesson, you worked with diagrams that were either supplied by 

is unit, you create and populate a new 
ly 
ils 

 by clicking the 
aximize button in the upper right corner of the window. 

6 You may want to change the data flow lines from stra
to elbow.  This can be done by highlighting the line a
then selecting Line Settings from the Options menu a
changing the line orientation to elbow.  Or click the elb
line button on the control bar before drawing the lines.  
 
To change the orientation of an elbow, position the cu
over the line segment handle to change and click, but do 
not release, the left mouse button.  Move the mouse 
slightly until the line changes from solid to dashed, and 
then press the right 

 

symbol is considered attached to a lin

automatically connect to the symbol.) 

Select Save from the File menu. 

AGRAM C
In prev
Visible Systems or created by the Spawn function. In th
diagram yourself and practice more data flow diagramming techniques. You  structural
decompose the process Administer Road Test (drawing a level-three diagram) that deta
what occurs within the process Administer Road Test. 
 
If you have any other diagrams open, you should maximize the window
M
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Set the Zoom Level: 1 Set the zoom level to 66% from the View menu. 
 
 

2 Select Nest from the File menu. 

3 Select Parent from the submenu. You move up the 
to display the diagram Driver’s Licensing 

as the current object. 

d automatically. This option is useful to drag 

wn with your input 

ows, select 33% zoom from the View menu and your 
 that you 

       

Open the Parent   
Diagram: 

diagram tree 
System. 
 

Nest a Process:  4 With the left mouse button, select the process symbol  
Administer Road Test by clicking on it. It is highlighted  

 
5 t Nest and then Explode. From the File menu, selec

 
6 Choose Create New Diagram. If you had previously 

is process, the child diagram would have nested th
displaye
down new data flows that you may have drawn on the 

ter the child diagram parent diagram to child diagrams af
as been created. A new diagram is drah

flows in the upper left corner of the diagram, and the 
t flows in the upper right corner. If you cannot see outpu

the fl
diagram, shown in Figure 8-5, scales down so
can see more of it. 

 
 

  
  
   gure 8-5  Exploded Diagram with Flows Fi
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Save:   7 

ms. This is because they are involved in a nest 
relationship and both ends of the nest relationship must be 

dding Processes to a Child Diagram 
ow add processes to the child diagram named Administer Road Test. The processes 

ontained in this diagram are the individual processes that make up the parent process 
dminister Road Test. This diagram is a more detailed representation of the transformations 

nd interactions that occur to the data flows within the parent process. 

dd Processes:  1 Click the first symbol button, process, in the control bar. 

2 Add and label three processes: Validate Applicant, Test 
Vehicle Knowledge, and Test Driving Capabilities. 

 
ave:   3 Select Save from the File menu. 

ttaching Data Flows to Symbols 
he input data flows on the left side of the diagram and the output data flows on the right side 
f the diagram were dragged down to the child diagram with the Nest function. It is 
ecessary to attach the data flows to the appropriate processes on the child diagram. To attach 
 flow to a symbol: 

elect a Line:  1 Put the cursor in selection mode by clicking the Ñ 
button on the control bar. 

 
2 Select the data flow Learners-Permit. The line handles  

appear. 
 

Drag It Into Position: 3 Drag it to the edge of the process symbol labeled Validate  
Applicant, as shown in Figure 8-6. 
 

Repeat for Other Flows: 4 Attach the other dragged-down flows as shown in Figure  
6-6. 

 
Add New Flows:  5 Click the first line button on the control bar. 
 

Select Save from the File menu and click OK. The title  
of your diagram defaults to the name of the parent  
process. Visible Analyst indicates that it is saving both 
diagra

saved in the repository. 
 

A
N
c
A
a
 
A
 

 
S

A
T
o
n
a
 
S
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6 Add a flow from process Validate Applicant to Test 
Vehicle Knowledge and label it “Valid-Applicant.” 

liberate error is added 
to demonstrate the capabilities of  the Analyze function.) 

  
9 Add an unattached data flow labeled “Driving-Criteria.” 

(Remember, you must double-click to end the line when it 
is not attached to a symbol.) This demonstrates the ability 
to select an existing flow from the diagram when a flow is 
split. 

 
Save:   10 From the File menu select Save. 
 
 
 
 
 
 
 
 
 

 

 
 
 

 
7 Click the straight line button on the control bar and add an 

input flow into the process Test Driving Capabilities and 
label it “Test-Criteria.” 

 
8 Add a flow from process Test Vehicle Knowledge to 

process Test Driving Capabilities, but leave it unlabeled 
by clicking Cancel or pressing ESC when you are 
prompted to enter a name. (This de
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        Figure 8-6  Child Diagram with Processes and Flows 

Splitting Data Flow
Decomposing, or “splitting,” a data tput 
data flows into subflows, creating m The 
oncept is illustrated in Figure 8-7. Th cess 

 showing more complex ta flow r 
or even atomic data flows at the low
decomposition capability provides 

henever a dragged-down data flow is sp  
nt diagram and re ced by

 
 

 

s 
 flow offers the capability to divide net input or net ou
ore detailed representation on lower-level diagrams. 

is capability greatly aids in the system analysis proc
by da s at high levels of the structured specification and smalle

er levels of the structured specification.  This 
a better understanding of the entire system and its parts. 

lit into subflows, the original flow is erased fromW
the curre pla  the selected or created subflows. 
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             gure 8-7  Splitting a Data Flow  Fi  

elect a Flow to Split: 1  put the  

mouse button. 

 

4 In the box labeled Enter Subflows, type in “Vehicle-

is 
 Figure 8-8. If you want to add more than one 

 
 
S Click the Ñ button on the control bar to

cursor into selection mode. 
 

2 Display the Object menu for the data flow labeled Road-
Test-Criteria by clicking on one end of it with the right 

 
3 Choose Split Data Flow. Start the Split:  

 

Familiarity-Criteria.” This option draws a new flow (a 
subflow of Road-Test-Criteria) on the diagram with th
label. See
name in this box, press ENTER to place the cursor on a 
new line. 
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            Fi

his option allows you to select an 

 
6 o 

added to the diagram. 

est 
 

 is 
ussion of Analyze.) 

 FOR BALANCE AND COMPLETENESS 
s a project goes through a number of nested decompositions (nests), data flow splits, various 

object moves and other ed procedures, there is a significant possibility that various data 
flows are incorrectly used, r that objects are forgotten, etc. For a large project with many 
symbols and flows, this is a real probability; and the errors are not easily detected by visually 

gure 8-8  Split Data Flow Dialog Box   
 

5 In the box marked Select Flows from Diagram, click 
Driving-Criteria. T
existing flow to be a subflow of Road-Test-Criteria. 

Click OK. Notice that the flow Road-Test-Criteria is n
longer on the diagram and that the flow Vehicle-
Familiarity-Criteria has been 

 
7 Attach the flow Driving-Criteria to the process T

Driving Capabilities with the arrow pointing away from
the process symbol. (This error is made deliberately; it
explained during the disc

 
8 Ignore the data flow Vehicle-Familiarity-Criteria, as 

another test for Analyze. 
 

ANALYZING
A

it 
o

 121 
 

 



Data Flow Diagrams 
 

checking the diagrams yourself. The Analyze function, found on the Diagram menu, is 
designed to warn you of completeness and logic errors. The function checks diagrams for: 
• Labels on all objects. 
• Unattached objects. 
• At least one input flow and one output flow for each process. 
• Data flow balance, which implies that an input flow is used everywhere as an input flow 

rather than an output flow and that data flows are properly accounted for at all levels of 
the diagram hierarchy. 

 
The diagram is now analyzed for adherence to the rules of the Gane & Sarson methodology. 
Those rules are outlined in the Visible Analyst Operation Manual and in the online help. 
 
Analyze the Diagram: 1 Select Analyze from the Diagram menu. 
 

2 Select Current Diagram and click OK. 
 
Visible Analyst displays the errors found. To display the errors full screen, click the 
Maximize button in the upper right corner of the error window. If an error message extends 
beyond the box, use the scroll bar at the bottom of the box to scroll the text to the left. There 
should be five messages. 
 
Data Flow labeled   This indicates that Vehicle-Familiarity-Criteria is not  
‘Vehicle-Familiarity-  attached to a process. 

riteria’ is dangling. 

u left unlabeled on the  
ata Flow(s).   diagram. 

  
 the  

agram. 
rocess. 

 
‘Driving  as a net  
should be sh  input  
input Data F
 
Input Data F
‘Road-Test-Criteria’   Familiarity-Criteria, a child flow of Road-Test-Criteria is  

h  
it appears on the diagram. 

C
 

here are 1 unnamed   This is the data flow that yoT
D
 
Net input Data Flow  This indicates that the data flow Test-Criteria has been
‘Test-Criteria’ is not   added to the child diagram but is not accounted for on
shown attached to parent   parent di
P

-Criteria’   This indicates that Driving-Criteria is being used
own as a net  output flow on the diagram, while it is used as a net
low.   flow on the parent. 

low    This message is a result of the fact that Vehicle- 

on parent is not shown.   not attached to a process as a net input flow, even thoug
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Note 
� Analysis error dialog boxes allow you to keep them on the screen while you 

carry on various Visib
t the er rs foun pen, 

press ESC or click Cancel to close it. 

ixing the Errors 
orrect the Data Flows: 3 Attach the data flow Vehicle-Familiarity-Criteria to the  

process Test Vehicle Knowledge, as shown in Figure 8-9. 
 

4 Reverse the direction of Driving-Criteria, so that it 
becomes an input flow to Test Driving Capabilities (see 
Figure 8-9), by dragging the endpoints. 

 
5 Delete Test-Criteria by clicking on the line and pressing 

the DELETE key. 
 

6 Label the unlabeled data flow “Vehicle-Knowledge” by 
clicking on the line with the right mouse button and 
selecting Change Item from the Object menu. Then 
enter the label and click OK 

 
Analyze Again:  7 Select Analyze from the Diagram menu again. 
 

8 Choose Current Diagram and click OK. The diagram 
should now be correct. 

 
Note 

� It is unnecessary to save a diagram after Analyze has been performed because 
Visible Analyst automatically saves it for you before analysis begins. 

 

  
 
 
 

 

le Analyst activities. This is to make it easier for you to 
correc ro d by Analyze. If you don’t want to keep the box o

 

F
C
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                                     Figure 8-9  The Completed Diagram 
 

GENERATING A PROCESS DECOMPOSITION MODEL 
A process decomposition model for a process shows you the hierarchical structure of a 
decomposed process that has been nested. 
 

Note 
� A process decomposition diagram is very different from a functional 

decomposition diagram. The former is simply an unstructured diagram 
displaying the hierarchy of processes that are descendants of an indicated 
process. The latter, discussed in Lesson 4 -Functional Decomposition Diagrams, 
is a full diagramming methodology for performing business planning. 

 
Open the Diagram: 1 From the Window menu, click “DMV System: DFD.” 
 
Select a Process:  2 Click the process Driver’s Licensing System with the  

right mouse button. 
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Create the   3 Select Decompose. An unstructured di
Decomposition:   showing the hierarchical structure of th
 
Save the 

 

      Figure 8-10  Process Decomposition Diagram 

agram is generated  
e process. 

New Diagram: 4 Select Save from the File menu. Label the diagram  
“Process Decomposition” and click OK. 
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